手机站:/m

免备案CDN_如何使用淘客app定制-阿里云服务器_折扣

时间:2021-09-03 08:46编辑:淘客樊里来源:淘客樊里当前位置:主页 > 云存储 >

我们已经发布了新版本的sapcloudsdk。具体来说,新版本中提供了以下组件:

版本3.22.0中的Java库版本1.21.2中的JavaScript库v36版的持续交付工具包

在这篇博文中,我们将引导您了解这些版本的亮点。要获得完整的概述,大数据包括哪些内容,请访问我们的Java库、JavaScript库和持续交付工具包的发行说明。发行说明还包括到目前为止我们所有发行版的更改日志。在文章的最后,您将找到一组关于如何更新到新版本的说明。

您可以将SAP Cloud SDK for Java的依赖项更新到3.22.0版本,美国云服务器,并从Maven Central获取新版本。

OData批处理请求(新实验API)

此版本包含一个用于使用发布通用OData批处理请求的实验APIODataRequestBatch。此实现支持实体读取和修改请求的批处理。修改在变更集中分组,并且根据服务实现的不同,如果变更集中的更改不成功,它们将回滚。可以附加多个变更集和读取请求。

示例代码:

请注意,API尚未被视为最终版本。

进一步的改进

完整的发行说明中列出了一些进一步的改进。

SAP Cloud SDK的JavaScript库现在在版本1.21.2中可用。

在几个错误修复中,我们解决了一个问题用于获取JWT验证密钥的URL缺少验证。

进一步改进

与往常一样,完整的发行说明包含此版本中所有改进的列表。

我们还发布了v36版本的开箱即用连续交付产品,包括现成的Jenkins服务器和完整的交付工具包。

虽然这是一个维护版本,但它包含一些改进。

您可以找到所有修复以及完整发行说明中的改进。

Java库

要更新现有项目中使用的SAP Cloud SDK Java库的版本,请执行以下操作:

打开pom.xml文件文件位于项目的根文件夹中。找到dependency management部分,并在其中找到sdkbom依赖项。将该依赖项的版本更新为3.22.0.

这样,您就可以使用"物料清单"(BOM)方法了。您的依赖关系应该是这样的:

如果您从3.0.0之前的版本更新,买云服务器,请查看我们的迁移指南。

如果您在SAP云应用程序编程模型的项目中使用SAP Cloud SDK,请将SDK bom替换为SDK模块bom,以仅更新SDK模块的版本,而不是进一步的依赖关系。现在,您可以重新编译您的项目(注意兼容性说明),并利用3.22.0版SAP Cloud SDK的新功能。

当然,返利,通过运行Maven archetypefor Neo或Cloud Foundry的-DarchetypeVersion=3.22.0(或发行版),您还可以生成一个从一开始就使用版本3.22.0的新项目。

JavaScript库

要更新现有项目中使用的SAP Cloud SDK JavaScript库的版本,请使用您的根文件夹中的命令npm update模块。请注意,这还将更新其他模块,除非您明确指定要更新的包。如果您想事先检查将要更改的内容,请使用npm-outloaded.

连续交付工具包

如果您使用的是固定版本的管道(从v7开始推荐),请使用以下命令更新连续交付工具包,在cx服务器所在的服务器上运行:

要了解社区中其他人如何使用SAP Cloud SDK,您可以查看更多相关的博客文章。

您对某个特定主题感兴趣吗?搜索问答地点可能会有帮助?请随意提问,不要忘记选择标签SAP Cloud SDK。

如果您是SAP Cloud SDK新手,请按照我们的教程开始并获得第一手的练习。

,开始云

上一篇香港服务器_cd京淘客-n服务器托管_怎么买

下一篇没有了

云市场知识本月排行

云市场知识精选